In order to have your files working with previous versions of Poser without that annoying message, just change the version number into the one you want to use your file in:

Et voilĂ !

The version number you can see on the examples are for compatibility. If you want your file to be compatible with Poser 4 version, just change the version number to 4.01